Visual studio 2013 & C++11

Mar 17, 2015 at 5:32 PM
Hi - great addin, have been using it extensively for a derivative pricing system.

I'd like to upgrade to visual studio 2013 so I can take advantage of the new features in C++11.

Any plans to update to VS 2013? Alternatively, so you know how would I go about doing this manually in VS 2013?

Thanks again!

Richard.
Coordinator
Mar 17, 2015 at 5:56 PM

Thanks Richard. Glad you find it useful.

Just open in VS 2013 and build. Works with 64-bit too.

You might want to try https://xll8.codeplex.com. It only builds in VS 2013 J It is then next version of the library rewritten for C++14.

Please give me feedback on your experience using the library. Anything you wish it could do but doesn’t?

I know a thing or two about derivatives. You might enjoy reading http://kalx.net/ftapd.pdf.

-Keith

Mar 19, 2015 at 12:20 AM
Thanks - worked first time (I built the xll project in vs 2013 and then linked my upgraded vs2013 project to the v120 version of the xll.lib). Now I am enjoying using for(auto x : v) etc.

The library does everything I need right now - and the end users like the results, especially the performance.

The main problem I have is managing deployment: I use the workbook_open() method in excel to load the xll but this is unreliable when the addin is in different places. Is there a better way?

Thanks for the paper!
Coordinator
Mar 19, 2015 at 1:12 AM

I like when things work. That doesn’t happen by magic.

Why not use the Add-In manager? It just involves setting a registry entry. No need to drag VBA into this, but I might be missing something about your setup.

I’m way past that paper in my thinking now. You might also like https://libfms.codeplex.com. It is no Quantlib, but I put that together for a course I taught last semester. Click on Source Code for the documentation.

May 21, 2015 at 9:44 AM
Hi - have an interesting problem with xll after I build with visual studio 2013. I have deployed it to one of my users and they are getting an error when they open it in excel:

"The format and extension of myfile.xll don't match. The file could be corrupted or unsafe. Unless you trust its source, don't open it. Do you want to open it anyway?"

clicking "Yes" opens up the "import text file" dialogue and it tries to read in the xll file as text.

I googled the problem and it seemed to be related to building in debug mode

(e.g. https://support.microsoft.com/en-us/kb/194926)

I have been building in release mode - and have tried setting the Debug Information Format to "Program Database" or "None" but get the same error.

Have you ever seen this before? Any ideas how to fix.

The "interesting" part is that it works fine on my machine.
Coordinator
May 21, 2015 at 10:37 AM
Setting to Program Database usually works. It might be that a dll is missing on the target machine.
You can use http://dependencywalker.com/ to find out if this is the case.
May 21, 2015 at 10:46 AM
Ahah - thanks! The target machine is missing python27.dll that I built against in the latest release.
Coordinator
May 21, 2015 at 10:51 AM
Just curious, but what features of python are you using?