fatal error message shows up when building XLL.Function in release model on Win32.

Oct 21, 2012 at 8:10 PM

xll.lib(XLCall32.dll) : fatal error LNK1112: module machine type 'x64' conflicts with target machine type 'X86'

 

 Hi, I am new here.

I was able to build and run XLL.Function in debug mode "Win32", but when I start to build it in release mode, I got above error.

 

Please advice.

Thanks!

garyX

Coordinator
Oct 21, 2012 at 8:40 PM

Try reinstalling setup.msi and project.msi from the xll home page.

Oct 21, 2012 at 9:03 PM

Hi Keith,

Thanks for replaying! Please allow me to ask if you were able to build in release mode before I reinstall setup and project. If so then I will proceed. Why x64 in getting into the way at the first time. xll was installed in Program file (x86)\Microsoft visual studio 10.0\vc\vcprojects.

I might need to reinstall both xll and vs studio c++ 2010 express. Do you think so?

Coordinator
Oct 21, 2012 at 9:06 PM

It is safe to assume that I test things before releasing them. I have no idea why you are seeing that error. Only setup.msi and project.msi need to be reinstalled.

Oct 21, 2012 at 9:24 PM

Hi Keith,

It works!!! I reinstalled setup and project msi files by save them and extract to local folders first, then click setup and project msi files. The first time I install them was directly click "Run" button from your remote sever. I guess this is trick you might want to share with new ones like me:)

Another question, after release Win32 was built, I can locate the xll executable under

C:\Users\...\Documents\Visual Studio 2010\Projects\XllProject1\Release

and run it successfully by double click the xll file.

But when I perform control+f5 from vs studio, it complaints about not able to file the xll file from the same directory.

This is less a concern because I do not have to control+f5 to run the release executable, as long as debug mode "f5" is fine, and release mode works by click the xll. A way to solve this issue might be my environmental variable setting to identify "c:\Users\...\Document\..." and c:\Users\...\My Document\..." as the same.

Anyway, This is an awesome lib!

Coordinator
Oct 21, 2012 at 9:31 PM

F5 only works in Debug mode. If you want to debug in Release mode you can copy Properties, Debugging from Debug to Release, but you probably won't have a good time.

Glad you like it. Please keep giving me feedback on how to improve it.